当前位置:首页 > 问答

两个选股公式怎么合并

我来帮TA回答

请高手把两个选股公式合并为一个?

可以把两个选股公式合并为一个,效果如下图

怎么样将2个选股公式合并在一起使用?

选股公式只能通过一个条件来选取,你现在想把二个选股公式合并成一个选股公式,可以这样做:
XG1:=A
AND
B;
XG2:=C
AND
D;
合并:XG1
AND
XG2;

2个选股公式怎么合并

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
XG:CROSS(REF(D,1),REF(K,1)) AND CROSS(K,D) AND D>50 AND (REF(C,3)-C)/C>0.05;
------------------------------------------------
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
XG:CROSS(REF(DEA,1),REF(DIFF,1)) AND CROSS(DIFF,DEA) AND (REF(C,3)-C)/C>0.05;

请教高手如何能将以下两个公式合并成一个选股公式,谢谢!

DIFF:=EMA(CLOSE,7) - EMA(CLOSE,19);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
XG:B1>0 AND B2>0;

一条均线的角度大于45度,通达信选股公式如何编写呢?

角度:=atan((MA(C,n)/ref(MA(C,n),1)-1)*100)*57.3;
大于45度选股:角度>45;
n日均线,其中的n值自己设置修改。
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

求20日均线角度大于45度选股公式

MA1:=MA(C,10);
MA2:=MA(C,20);
角度10:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
角度20:=ATAN((MA2/REF(MA2,1)-1)*100)*180/3.1416;
XG:角度10>0 AND 角度20>45;

(已测试)